The migration to MS Teams calling has been completed. All phone numbers have been moved to the new carrier. New physical devices have been deployed and tested. Please contact the ITS Help Desk with any persistent issues.
Posted Jan 16, 2026 - 18:00 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 16, 2026 - 14:02 EST
Scheduled
Beginning now, Information & Technology Services (ITS) will begin the process of porting the College’s external phone numbers to Microsoft Teams, and inbound calls may see brief disruptions during this time. The process is expected to take approximately 30-60 minutes.
Once the porting is complete, inbound calls from external numbers will ring directly in Teams. ITS will then visit buildings to install the new phones in shared workspaces and high call volume locations, followed by collection of the Cisco desk phones from offices.
Progress updates will be posted here.
Posted Jan 16, 2026 - 14:01 EST
This scheduled maintenance affected: Phones & Voicemail.