This issue has been resolved. The ITS team will continue to monitor these systems. Please report any additional problems to the Help Desk by opening a ticket at helpdesk.etown.edu, emailing helpdesk@etown.edu, or calling 717-361-3333.
Posted Dec 02, 2025 - 12:06 EST
Update
We are continuing to monitor for any further issues.
Posted Dec 02, 2025 - 12:05 EST
Monitoring
While our networking team continues to work to ensure stability, all services should be working as expected at this time. If you are experiencing any continuing issues, please reach out to our Help Desk at helpdesk@etown.edu.
Thank you.
ITS
Posted Nov 28, 2025 - 17:00 EST
Identified
The issue with inbound calling has been identified and we are workign to stabilize the service.
-ITS
Posted Nov 28, 2025 - 15:35 EST
Investigating
Our team is actively working to resolve some ongoing issues following today's maintenance. The most critical service currently affected is inbound phone calls, which may not be completed. We appreciate your patience as we continue working to restore full functionality. We’ll provide another update shortly.
Thank you for your understanding.
ITS
Posted Nov 28, 2025 - 15:07 EST
This incident affected: Phones & Voicemail and Other Services.