All systems have continued to remain stable overnight and services are fully operational. Please report any additional needs by opening a ticket with the Help Desk at helpdesk.etown.edu. Thank you.
Posted Apr 10, 2026 - 11:20 EDT
Monitoring
All campus services have been restored to working order. ITS teams continue to monitor to ensure continued stability. Thanks for your patience as we worked through this unanticipated disruption to services.
Posted Apr 09, 2026 - 22:12 EDT
Update
The impacted equipment has been bypassed allowing restoration of primary networking services, Wi-Fi, and Internet connectivity. The ITS team will continue to work through reviewing system health to verify that all services have been restored.
Posted Apr 09, 2026 - 20:54 EDT
Identified
ITS has received multiple reports of a network service disruption on campus. A team has arrived on campus and has identified the underlying issue. The team is working to restore services.
Posted Apr 09, 2026 - 20:33 EDT
This incident affected: Internet, Wireless, Jayweb, Printers and Printing, and Other Services.