Canvas Outage

Incident Report for Elizabethtown College

Resolved

Instructure has officially resolved the current Canvas incident and has confirmed a second security breach. Both recent incidents originated through their "Free for Teachers" accounts. As services have been restored, we are closing our local monitoring of the incident.

For more detailed information about these incidents, their impact, and Instructure's response, please visit https://www.instructure.com/incident_update.
Posted May 08, 2026 - 08:23 EDT

Identified

We are currently aware of an outage affecting access to Canvas. This appears to be a widespread issue with the service provider (Instructure) rather than our local systems.

While we are unable to resolve the issue directly, we are closely monitoring the situation and will provide updates as soon as the service provider shares more information.

For more information or to monitor directly, please view the incident at https://status.instructure.com.
Posted May 07, 2026 - 16:50 EDT
This incident affected: Canvas.