Global Disruption Reported by CrowdStrike
Incident Report for Elizabethtown College
Postmortem

As indicated, the global disruption related to CrowdStrike has impacted some of our services which interacted with "third-party" providers who utilize the CrowdStrike platform. We have continued to monitor and remediate services as applicable. At this time, all services are once again fully operational. 1) Please return to using the Facilities Work Order System 2) The Office of Marketing and Communications request forms are now available 3) And, the Business Office has returned to normal operations for payment processes Thank you for your awareness and patience as we were impacted by this disruption. ITS

Posted Jul 24, 2024 - 10:28 EDT

Resolved
As indicated, the global disruption related to CrowdStrike has impacted some of our services which interacted with "third-party" providers who utilize the CrowdStrike platform. We have continued to monitor and remediate services as applicable.

At this time, all services are once again fully operational.
1) Please return to using the Facilities Work Order System
2) The Office of Marketing and Communications request forms are now available
3) And, the Business Office has returned to normal operations for payment processes

Thank you for your awareness and patience as we were impacted by this disruption.

ITS
Posted Jul 24, 2024 - 10:28 EDT
Monitoring
We are continuing to monitor our services in relation to the global CrowdStrike disruption last week.
Posted Jul 22, 2024 - 13:51 EDT
Identified
A global disruption of services has been reported by CrowdStrike. While internal Etown network systems are not affected, third party services that utilize the CrowdStrike platform may be impacted.

At this time we have identified the following services as impacted...

1) The Facilities Management work order system is impacted and will be unavailable. Urgent Facilities service requests should be directed to Campus Security at 717-361-1264.

2) Office of Marketing and Communications Campus News and Achievements Request Forms – Please email all Campus News E-newsletter submissions to campusnews@etown.edu and email all achievements or story ideas to now@etown.edu.

3) The Business Office is currently unable to process PCard adjustments or wire/ACH payments. Please contact the Business Office (717-361-1417) with any questions.
Posted Jul 19, 2024 - 09:23 EDT
This incident affected: Other Services.