Internet Connectivity - Investigating Reported Incident

Incident Report for Elizabethtown College

Monitoring

Our Internet connectivity has been stabilized and services have been restored. The ITS team will continue to investigate and monitor. Please open a ticket with the Help Desk (helpdesk.etown.edu) for any additional issues. Thank you.
Posted Sep 10, 2026 - 16:00 EDT

Investigating

ITS is currently investigating an incident that has been reported with connections to the Internet from campus. Internal services appear to be operational, but services connecting to the Internet from the campus are impacted. We will provide updates to the status as they are available.
Posted Sep 10, 2026 - 15:41 EDT
This incident affects: Internet.