Campus Internet Routing Issue

Incident Report for Elizabethtown College

Resolved

Continued monitoring shows stable connectivity. We are closing this incident. Please do not hesitate to reach out to the Help Desk if you see any persistent issues. Thanks! -ITS
Posted Aug 12, 2025 - 10:23 EDT

Monitoring

An incorrect internet routing restriction has been identified and removed. All internet traffic should be operational as expected. Continuing to monitor for consistent stability.
Posted Aug 12, 2025 - 09:04 EDT

Investigating

ITS is currently investigating an internet routing issue impacting users' ability to access certain web pages and services while using campus internet. Further updates will be provided as available.
Posted Aug 12, 2025 - 08:43 EDT
This incident affected: Internet.