etown.edu pages unavailable

Incident Report for Elizabethtown College

Resolved

Continued monitoring has shown our site has been returned to expected performance. This issue is now considered closed. If you continue to see any inconsistent behavior on the etown.edu website, please let us know by contacting our Help Desk. Thank you. -ITS
Posted Aug 04, 2025 - 13:04 EDT

Monitoring

A solution has been identified and we are currently monitoring any unexpected outcomes. If you continue to see any issues accessing the Etown website. Please reach out to our Help Desk. Thank you. -ITS
Posted Aug 04, 2025 - 11:34 EDT

Investigating

ITS is investigating an issue preventing certain etown.edu web pages from loading properly. ITS and OMC are working together to resolve the problem and restore access. Further updates will be provided as available.
Posted Aug 04, 2025 - 10:17 EDT
This incident affected: Other Services.