Jenzabar - Investigating Reported Incident

Incident Report for Elizabethtown College

Resolved

Monitoring and testing has confirmed that the problem has been resolved.

Please report any new issues to the ITS Help Desk via a ticket at https://helpdesk.etown.edu.
Posted Mar 19, 2025 - 14:45 EDT

Monitoring

The problem has been narrowed to a Microsoft security patch and work has been completed to roll back this patch. Initial testing has confirmed that services have returned to normal. The ITS team will continue to monitor services.

Please report any on-going issues to the ITS Help Desk via a ticket at https://helpdesk.etown.edu.
Posted Mar 19, 2025 - 11:46 EDT

Investigating

ITS is currently investigating reports that processes within Jenzabar are not completing consistently, affecting multiple Jenzabar modules and integrations.  We will provide updates to the status as they are available.
Posted Mar 19, 2025 - 09:13 EDT
This incident affected: Jayweb and Other Services.