Internet trouble

Incident Report for Elizabethtown College

Resolved

The connectivity issue that was affecting traffic between the local campus network and the Internet has been resolved. The ITS team will continue to monitor these systems. Please report any additional problems to the Help Desk by opening a ticket at helpdesk.etown.edu, emailing helpdesk@etown.edu, or calling 717-361-3333.
Posted Dec 02, 2025 - 12:03 EST

Monitoring

A fix has been implemented and we are monitoring for further instability. Please reach out to the Help Desk to report any further problems at helpdesk@etown.edu or 717-361-3333
Posted Dec 02, 2025 - 11:22 EST

Investigating

ITS has received reports of internet connection dropping across campus as of 10:21 AM. We are investigating the issue.
Posted Dec 02, 2025 - 10:34 EST
This incident affected: Internet and Wireless.