Barracuda Portal for e-mail Quarantine Management
Incident Report for Elizabethtown College
Resolved
This incident has been resolved. We have seen no other reports since our last update. If you do have problems with this service. Please do not hesitate to reach us at helpdesk@etown.edu. Thanks!!
Posted May 30, 2023 - 09:19 EDT
Update
Barracuda has informed ITS that the issue has been resolved. If you still have a copy of the quarantine email messages from Barracuda Networks, the "VIEW MESSAGE LOG" link should open the page for the list of quarantined emails. Please let ITS know if you are still having issues at helpdesk@etown.edu or 717-361-3333.
Posted May 24, 2023 - 13:29 EDT
Monitoring
Barracuda has updated the case and said that they are aware of the issue with the "Manage Quarantine" link in the Quarantined notification email message not working. The workaround is to use the following link, https://ess.barracudanetworks.com to log into the portal. If you need to access the portal, please use that link. If you have any questions or issues, please contact the help desk at helpdesk@etown.edu or 717-361-3333.
Posted May 23, 2023 - 11:13 EDT
Identified
There is an issue with the Barracuda Portal to Manage Quarantined e-mail messages. Their Technical Support is continuing working on the issue since last night with no resolution yet. When logging into the Barracuda portal, you may get a message of "Please wait..." and then a message of "The link to login is invalid". If you have an item that needs released immediately, please contact the help desk at 717-361-3333 or helpdesk@etown.edu.
Posted May 23, 2023 - 09:16 EDT
This incident affected: Microsoft 365 (including Email) and Other Services.