CANVAS - Investigating Reported Incident
Incident Report for Elizabethtown College
Resolved
Canvas reports that the issue has been resolved: https://status.instructure.com/. Please report any additional problems to ITS (helpdesk@etown.edu or 717-361-3333).
Posted Sep 27, 2022 - 15:45 EDT
Update
We are continuing to investigate this issue.
Posted Sep 26, 2022 - 11:49 EDT
Investigating
Canvas is reporting:

Users are experiencing Slow Load Times and Page Time Outs when accessing Canvas.

We will provide updates to the status as Canvas makes them available.
Posted Sep 26, 2022 - 11:47 EDT
This incident affected: Canvas.