Xfinity On Campus - Authentication Issue
Incident Report for Elizabethtown College
Resolved
Comcast engineering has resolved the authentication issue with Xfinity on Campus. Please report any additional problems to ITS (helpdesk@etown.edu or 717-361-3333).
Posted Jun 27, 2022 - 11:29 EDT
Identified
ITS is currently investigating reports of authentication errors when trying to log-in to Xfinity on Campus. The problem has been identified and requires an update to be applied by Comcast. A support request is currently open with Comcast engineering to have this change made. We will provide updates to the status as they are available.
Posted Jun 21, 2022 - 12:26 EDT
This incident affected: Other Services.