Mac Network Printing- Investigating Reported Incident
Incident Report for Elizabethtown College
Resolved
The incident with Mac Network Printing has been resolved. Please report any additional problems to ITS (helpdesk@etown.edu or 717-361-3333).
Posted Jan 27, 2022 - 14:48 EST
Investigating
ITS is currently investigating an incident that has been reported with Mac Network Printing. We will provide updates to the status as they are available.
Posted Jan 27, 2022 - 11:00 EST
This incident affected: Printers and Printing.