Internet Email Disruption

Incident Report for Elizabethtown College

Resolved

Barracuda Networks has implemented a fix. Their public disclosure states the issue arose when a configuration change impaired their virtual computing capacity to expand with increased workloads. Once that was corrected, mailflow returned to normal levels.
Posted Jul 16, 2025 - 14:10 EDT

Monitoring

Barracuda Networks reports that they have implemented a fix and that mailflow is returning to normal levels. ITS continues to monitor the status of this incident.
Posted Jul 16, 2025 - 10:24 EDT

Identified

Barracuda Networks is facing a multiple region mailflow disruption - presently impacting US, DE, CA, EU. Barracuda support reports that our external inbound mail is being deferred. From testing within ITS, external outbound mail appears to be only slightly delayed.

Internal messaging (email from @etown.edu to @etown.edu) is not impacted.

We will provide updates as they are available. For more details, please visit https://status.barracuda.com/.
Posted Jul 16, 2025 - 09:24 EDT
This incident affected: Microsoft 365 (including Email).