Emails Delayed
Incident Report for Elizabethtown College
Resolved
While Barracuda Networks continues to monitor for further issues on their platform, we have seen our mail activity return to normal. As always, please reach out with any issues. We're here to help!
Posted Dec 06, 2022 - 07:58 EST
Monitoring
A couple of hours ago, an outage with a public cloud provider impacted our Barracuda Networks email security service. Barracuda reports this has been since resolved. However, there is a delay in mail delivery . We are monitoring as the systems catch up. There should not be a delay of more than a few hours. Please reach out if you experience message delivery failure.
Posted Dec 05, 2022 - 18:35 EST
Identified
Elizabethtown College subscribes to a cloud email security service provided by Barracuda Networks which is experiencing a global outage with public cloud providers. External emails (inbound and outbound) may be delayed. We have seen some cases where such emails flow normally but many emails have been impacted.

We have opened a support ticket with Barracuda. At this time we do not have any additional details. We will update this post as we learn more.

We apologize for any inconvenience and thank you for your patience as this issue is resolved by our service provider.
Posted Dec 05, 2022 - 16:17 EST
This incident affected: Microsoft 365 (including Email).