Printer issues
Incident Report for Elizabethtown College
Monitoring
We have identified a fix and implemented a solution. If you are experiencing trouble, please reach out to the Help Desk at 717-361-3333
Posted May 02, 2024 - 16:27 EDT
Investigating
We are investigating a issue where users are unable to print to Toshiba copiers on campus. The issue appears to be contained to only Toshiba printers. We will provide more updates shortly.
Posted May 02, 2024 - 10:47 EDT
This incident affects: Printers and Printing.